Support Center

Slow load of Imageman Image Control 7.3

Chad Newman Sep 24, 2013 10:37AM EDT

I'm using ImageMan ActiveX Image Control to handle the viewing and saving of images. I have one client where it takes between 30 to 60 seconds to the load the form that the control is on. When I remove it from the form and try to access it via my wrapper for saving a scan it takes 30 to 60 seconds to work the process.

It is only happening with this one client on several different computers and I'm not sure what to even look at or attempt to see if this can be changed?

Thanks,

Chad Newman
Black Mountain Software

4 Data Techniques Responses and 3 Community Responses

Up -1 Rated Down
DTI Support  Data Techniques Employee Sep 24, 2013 11:53AM EDT

Hello,

Is this in an Internet Explorer based app or is it VB 6 ?


Thanks,
Sean
Data Techniques Support

Up 1 Rated Down
Chad Newman  Data Techniques Employee Sep 24, 2013 01:28PM EDT

Sean thanks.
It is actually a Visual FoxPro Application using VFP 9.0.

Thanks,

Chad Newman
Black Mountain Software

Up 0 Rated Down
DTI Support  Data Techniques Employee Sep 25, 2013 08:59AM EDT

Hi Chad,

The only thing we can come up with is some type of Antivirus issue thats slowing the load down, we have seen this a couple times over the years,

Version 7.3 is rather dated at this point but there arent any known issues with behavior like this

Thanks for your interest in our products and please let us know if you have any questions.

Sincerely,
Sean
Data Techniques Support

Up -2 Rated Down
Chad Newman  Data Techniques Employee Sep 25, 2013 09:11AM EDT

Sean,
Thank you very much for the information. That really gives me a place to start!

Other than the IMGMAN32.DLL are there any other DLLs that IMACT33.OCX would access?

Going to try and have the client exclude from real-time AV anything associated with the OCX.

Thanks again,
Chad Newman
Black Mountain Software

Up 1 Rated Down
DTI Support  Data Techniques Employee Sep 25, 2013 09:15AM EDT

Hi Chad,

The OCX will only use the *.dil, *.del files as well as the imgman32.dll file.

Thanks for your interest in our products and please let us know if you have any questions.

Sincerely,
Sean
Data Techniques Support

Up -3 Rated Down
Chad Newman  Data Techniques Employee Oct 01, 2013 11:50AM EDT

Sean,

Thanks for the wonderful support that Data Techniques Support provides. I just wanted to provide and update on our situation and the solution.

The customer we were having the issue with doesn't have antivirus installed, but we install the IMACT33.OCX via a "runtimes" install and because of ways we did things differently, there is also a copy inside the application folder.

As soon as I removed the IMACT33.OCX and the DILs and DELs from the application folder our scanning and image viewing formed open immediately.

Thanks again,

Chad Newman
Black Mountain Software.

Up 2 Rated Down
DTI Support  Data Techniques Employee Oct 01, 2013 02:46PM EDT

Hi Chad,

Thanks for the update and glad to hear you got it working OK now.

Thanks for your interest in our products and please let us know if you have any questions.

Sincerely,
Sean
Data Techniques Support

This question is closed to new answers.

Contact Us