Support Center

error 18

Alan Jul 06, 2012 01:45PM EDT

Immediately after calling SendFax() logs show the following:

7/6/2012 12:33:19 PM - (Message)Starting pEngine-Process()
7/6/2012 12:33:19 PM - (Status Code 2) Initializing Modem Err=
7/6/2012 12:33:19 PM - (Message)Class 1 - Built on Feb 15 2008
7/6/2012 12:33:19 PM - (Status Code 4) Initializing Faxmodem for sending Err=
7/6/2012 12:33:19 PM - (Message)--
7/6/2012 12:33:19 PM - (Message)AT
7/6/2012 12:33:19 PM - (Message)Exiting Processs with Error: 18 in State 2
7/6/2012 12:33:19 PM - (Message)Ending pEngine-Process()
7/6/2012 12:33:19 PM - (Status Code 16) Comm Port Closed Err=

We have tried many different modem init strings (including those listed in Datatech Faxman manuals), different modems (same model), different COM ports, different server, and still get the same result. The modem works successfully with Hyperterm and Windows Fax. The modem is USR 56k FAX USB. OS is Windows 2003. FMJR10.dll 2.20.0.0.

Faxing did work until recently so there's a mystery as to why it's failing now.

What else can we try or do to get a better understanding of the issue?

1 Data Techniques Response

Up 4 Rated Down
DTI Support  Data Techniques Employee Jul 06, 2012 02:07PM EDT

Hello,

The error 178 is a 'generic' error unfortunately. When you use Hyperterminal to open the modem make sure you open the COM x version instead of the USR Fax modem option. That will open the port the same way FaxMan does. Look at this kbase article and see if you can open the port this way: http://help.data-tech.com/customer/portal/articles/334037-testing-a-modem-if-faxman-cannot-detect-or-use-it

Sean

This question is closed to new answers.

Contact Us