Support Center

Licensing path issue on Win7

Steve Oct 19, 2011 03:32PM EDT

I recently installed Windows7 and am now being presented with the ImageMan trial dialog when running my app. When I enter the license key into the prompt and click OK it then crashes. The cause of the crash is:
"Access to the path 'C:\Program Files\Common Files\DTI\Licenses' is denied."

First of all that path doesn't exist, so I'm not sure where it's coming from.
The license.licx file is embedded as a resource in the assembly so it's also odd that it's asking me for a license.

I'm using version 2 of the library:
DTI.ImageMan.Twain.TwainControl, DTI.ImageMan.Twain, Version=2.0.0.0, Culture=neutral, PublicKeyToken=xxxxxxxxxxxxxxxxxxxxxx

I realize I don't have support contract, but I'm hoping that someone out there can maybe give me some clues how I can start to try to fix this. The licensing is all closed off, I don't see how I can change anything to make it work.

1 Data Techniques Response and 1 Community Response

Up -1 Rated Down
Steve  Data Techniques Employee Oct 19, 2011 03:43PM EDT

I couldn't figure out how to edit my initial question so I'm hoping this "answer" feature will allow me to add content but not close this question.

So I read some of the suggested articles that popped up when I tried to post this question.

- I downloaded and installed ImageMan.Twain on this machine, even though I have not needed to do this on any of the other machines I work on. However I'm still getting the error
- I copied the license to the Properties folder of my executable project instead of the assembly that is actually using the DTI stuff, even though in the past 3 years I have not needed to do this. However I'm still getting the error.

What else can I try?
Is the licensing in newer versions improved? I'm using version 2 (although the DTI assemblies report 1.0.0.0) the installer is named ImNetTwain254.exe (version 2.54)

-Steve

Up -3 Rated Down
DTI Support  Data Techniques Employee Oct 19, 2011 03:51PM EDT

Hi Steve,

I would suggest you download the latest ImageMan.Net Twain installer from our website and run that on your development machine and rebuild your app. There were some changes to the licensing code between those builds which should resolve your issue.

Thanks for your interest in our products and please let us know if you have any questions.

Sincerely,
Sean
Data Techniques Support

This question is closed to new answers.

Contact Us