Support Center

fmprint4.ocx unable to register

PAt Black Mar 07, 2013 09:15AM EST

fmprint4.ocx fails to register on a Win Server 2008 machine. I get an exit code 0x3. The install program is "run as Administrator". I also tried by running CMD as administrator and typing the REGSVR32 command but it failed as well. "The module "C:.... fmprint4.ocx" failed to load.

2 Data Techniques Responses and 2 Community Responses

Up 3 Rated Down
DTI Support  Data Techniques Employee Mar 07, 2013 09:49AM EST

Hi,

Win32 error 3 is a path not found. Make sure when you call regsvr32.exe that you pass the full and complete path and filename of the ocx file.

Let me know if you still have a problem.

Sean
Data Techniques

Up -1 Rated Down
Pat Black  Data Techniques Employee Mar 08, 2013 08:49AM EST

Progress. The WIn Server 2008 security was causing problems. The directory where the file is located was read only. I modified so the user has full privledges. When run regsvr32 fmprint4.ocx in correct directory I get the following;

The module "fmprint4.ocx" was loaded but the call to DllRegisterServer failed with error code 0x80070005

Up 4 Rated Down
DTI Support  Data Techniques Employee Mar 08, 2013 09:18AM EST

Hello,

Googling this error seems to indicate its a permissions issue during registration, make sure you are running the cmd prompt 'As Admin' so regsvr32 has admin privileges.


http://social.technet.microsoft.com/Forums/en-US/itprovistasecurity/thread/71037d62-d842-44a3-86df-6ed74df6fc39/

Sean
Data Techniques Support

Up -2 Rated Down
PAt Black  Data Techniques Employee Mar 19, 2013 07:08AM EDT

Your suggestion worked. Thanks

This question is closed to new answers.

Contact Us